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Abstract
The Internet of Things (IoT) is transforming how we interact with the world around us, and its impact on the food industry is no exception. In this project, we present a novel approach to food quality supervision using IoT technology. The project involves using sensors and cloud-based data analytics to monitor various parameters related to food quality, such as temperature, humidity, and spoilage indicators. The data collected from the sensors is then processed in real time using machine learning algorithms, enabling us to detect any anomalies or potential issues with food quality. This approach to food quality supervision has several benefits, including early detection of issues, reduced waste, and improved overall food safety. We demonstrate the effectiveness of our approach through a proof-of-concept implementation, which shows promising results. Overall, our project provides a valuable contribution to the food quality supervision field, highlighting the potential of IoT technology in improving food safety and quality.
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Introduction
Food contamination can happen during production, still contaminated due to improper handling, also storage place,during shipment.The food is contaminated due to change of the weather,lights, moisture or due to acid and some kind of gases released . It is crucial to have a monitoring system that can track changes in temperature and humidity while being transported and stored. Nowadays almost all are having the  eagerness or addicted by the food . 
Even the canned food,packed items, veggies,fruits what is been used in our day to day life is spoiled.This is due to the weather,humidity changes ,food quality is not good.The buyers are neglecting the condition of the food itmes since they are looking more into the nutritional facts and spoiling their health.Manufacturers are attracting the people to buy their product by showing more promo so their product sold more rather worried about their health,say an example the food is added with some nice aroma flaovour,change of colors to attract and some kind of agents to food not to get spoiled.these manufacturers are least bothered about the health of common people,they focus on profit.Due to more moisture and climate change ,the product is spoled by microbes.Fungi typically targets more acidic tissue, but fruits and vegetables with pH levels above 4.5 are generally immune. 
Ensuring food quality and safety is of paramount importance in the modern food industry. The emergence of Internet of Things (IoT) technology has opened new possibilities for monitoring and supervising food quality throughout the supply chain. Integrating IoT devices and sensors into food production and distribution processes allows real-time data to be collected, analyzed, and acted upon to detect and prevent potential quality issues. This project, titled "Supervision on Food Quality using IoT," aims to leverage the power of IoT to create a comprehensive system that ensures the highest standards of food quality.
Literature survey
The author1 talks about the quality of food testing system whether it is good system or bad. This paper give the drawback of the old system for the testing the food. Here the study has done for the food quality testing system of different parameters and made a new system which has bettere result. The different parameters tested are their combinationsof different material, the different activity, their appearance, what and which way of usage, merits and demerits. 
The old system has the following[1]:
Strengths:

· Provides some level of monitoring by personnel.

· Can detect changes in the conditions of the food store.

· Requires minimal initial setup.
Weaknesses:

· Relies on periodic visits by personnel, leading to delays in identifying and addressing issues.

· Increased labour and costs associated with routine checkups.

· The danger or threat  to people due to bad conditions.

· Hidden mistake by   human  in calculation.
[2] Installed Measurement Devices monitoring systems:

Strengths:

· Improves upon manual monitoring by installing measurement devices.

· Can provide more accurate and continuous monitoring of environmental factors.

· Enables data collection for analysis and decision-making.
Weaknesses:

· Lacks automatic relay of information, requiring physical visits to access data.

· Delays in reading measurements due to manual retrieval.

· Device failures and maintenance requirements can impact reliability.

· May require additional costs for equipment installation and maintenance.
[3] Smart Food Quality Monitoring System:
Strengths:

· Systematic use of sensors for quality monitoring and control.

· Automation of tasks leads to better monitoring.

· Utilizes IoT technology for real-time data transmission.

· Cost-saving benefits by optimizing monitoring processes.

· Provides an interface for users to observe product quality evolution.

Weaknesses:

· Implementation and integration of various sensors and IoT components may require technical expertise.

· Initial setup and configuration can be complex.

· Potential challenges in data management and security.

· Reliance on wireless connectivity may introduce vulnerabilities.

In comparison, the manual monitoring system has limitations due to its reliance on human intervention and the potential for delays and errors. The installed measurement devices system improves upon manual monitoring but still lacks real-time data access. The smart food quality monitoring system offers automated and real-time monitoring using sensors and IoT technology, addressing the shortcomings of the other systems. However, it may require technical expertise for implementation and data management considerations.

By leveraging heterogeneous sensors, real-time data transmission, and data analysis capabilities, the proposed smart food monitoring system aims to overcome the limitations of existing solutions and provides advantages such as improved monitoring, cost savings, and time efficiency.

1.1 Design and implementation 
The new proposed system as shown in the block diagram is used to give the quality of the food using IOT. The following sensors and controller are used to test the quality of the food a DHT-11 temperature and humidity sensor, MQ4 Sensor, the LDR sensor and ESP32 as the microcontroller.
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Fig.1.1 Block Diagram for Supervision on food quality using IOT
A block diagram of the proposed method is shown in fig 1.1that shows its various components and their interactions.
The room's gas concentration is measured using a gas sensor, which gives voltage from the concentration of the gas.Even humidity and temperature sensor reads the the moisture level the room temperature. To reduce the costs, the two sensors are frequently used a lot. The light sensor is employed to gauge luminous level. The data from all the sensors is shown on the display device. The measured value of all sensors is transferred to the Internet by the monitoring system. Through an open-source Internet platform, the concerned parties can keep an eye on the food store's gas concentration levels, temperature, humidity, and light intensity.
1.2 Flowchart
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Fig.1.2Flow Chart forSupervision on food quality using IOT
The flow chart of food quality supervision  is  shown in figure1.2 ,shows the steps of the quality of the food measured by the system. The steps of the sequence is shown in the flow chart and code was written as per the steps shown.
1.3 ImplementationSteps
Implementation Steps for Supervision on Food Quality using IoT:

Hardware Setup:

a. Connect the ESP32 DEVKIT controller to your computer.

b. Connect the Light Dependent Resistor (LDR) sensors to the appropriate pins on the ESP32 DEVKIT.
c. Connect the DHT Temperature and Humidity Sensors to the ESP32 DEVKIT.
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          Figure 1.3.1 Interfacing DHT11 sensor  with ESP32
d. Connect the MQ-4 Gas Sensor to the ESP32 DEVKIT.
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Figure 1.3.2 MQ-4 sensor

e. Connect the O-LED display to the ESP32 DEVKIT.
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Figure 1.3.3 Interfacing OLED with ESP32
f. Ensure that all the connections are secure and properly wired  as shown in the below figure1.3.4.
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                                Figure 1.3.4 Hardware
Software Setup:

a. Downloading and installing the Arduino IDE software on your computer.

b. Open the Arduino IDE and go to "File" > "Preferences." In the "Additional Boards Manager URLs" field, add the URL for the ESP32 boards package: "https://dl.espressif.com/dl/package_esp32_index.json".

c. Next step: "Tools" > "Board" > "Boards Manager" and search for "esp32". Installation of the "esp32" boards package.

d. Chooses ESP32 board from the "Tools" > "Board" menu.

e. made the setup for the necessary libraries for the sensors and display. Go to "Sketch" > "Include Library" > "Manage Libraries" and search for the following libraries:
· DHT sensor library

· Adafruit SSD1306
· Adafruit GFX

f. The above libraries was installed successfully.
Coding:

a. Opened a new sketch in the Arduino IDE.

b. Started by including the necessary libraries at the beginning of your code.

c. Defined the pin connections and other constants for the sensors and display.
d. made set up the initializations and configurations in the setup () function.
e. Implemented the main functionality in the loop () function.

f. Uploaded the code to the ESP32 DEVKIT by clicking on the "Upload" button in the Arduino IDE.
IoT Platform Configuration:

a. An account is created on the Arduino IoT Cloud platform (https://create.arduino.cc/iot).

b. Followed the platform's instructions to set up your device and connect it to the Arduino IoT Cloud.

c. Configured the necessary variables, properties, and settings on the IoT dashboard to display and analyse the sensor data.
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                                                    Figure 1.3.5 IOT results
Testing and Deployment:

a. Verified that the sensor values are correctly displayed on the OLED screen and can also be viewed on serial monitor.

b. Monitored the sensor data on the Arduino IoT Cloud platform.

c. Fine-tuned the system as needed to ensure accurate monitoring and control of food quality.

d. Deployed the system in the desired location and ensure it is connected to the internet for remote monitoring and control.
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                                               Figure 1.3.6 Serial monitor output
The system was ready to read the data from all sensors and gives the data to Internet via Wi-Fi modem .Then the ESP32 collected the  data from all the sensors and changed to stringngs. The sensor data wrapped as proper strings are passed to the character OLED for display. Arduino cloud IOT platform was used to monitor the sensor data visually online.
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1.4 Conclusion
The implementation of an IoT-based system for food quality supervision offers significant benefits in enhancing food safety and quality control. Real-time data collection through IoT devices and sensors enables continuous monitoring and timely interventions. Data analytics and machine learning techniques improve the system's capabilities by analysing collected data to predict and prevent quality issues. The project highlights the importance of addressing challenges such as data security, integration with existing infrastructure, and scalability. Future advancements in IoT technology and emerging technologies can further revolutionize the food industry. Overall, the successful implementation of IoT for food quality supervision improves the safety and integrity of the food supply chain, ensuring consumer confidence.
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