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Abstract
The Internet of Things (IoT) is transforming how we interact with the world around us, and its impact on the food industry is no exception. In this project, we present a novel approach to food quality supervision using IoT technology. The project involves using sensors and cloud-based data analytics to monitor various parameters related to food quality, such as temperature, humidity, and spoilage indicators. The data collected from the sensors is then processed in real time using machine learning algorithms, enabling us to detect any anomalies or potential issues with food quality. This approach to food quality supervision has several benefits, including early detection of issues, reduced waste, and improved overall food safety. We demonstrate the effectiveness of our approach through a proof-of-concept implementation, which shows promising results. Overall, our project provides a valuable contribution to the food quality supervision field, highlighting the potential of IoT technology in improving food safety and quality.
Keywords: temperature, humidity, spoilage indicators using IOT technology
Introduction
Food contamination can happen during production, but it can also be brought on by ineffective food handling due to unfavourable environmental conditions during transportation and storage. Food poisoning can be caused by a variety of conditions, but frequently key ones include variations in light intensity, temperature, humidity and the presence of alcohol or different gases emitted when they are spoiled. It is crucial to have a monitoring system that can track changes in temperature and humidity while being transported and stored. Today, practically everyone is influenced by the food they eat. 
This is not just true of junk food, but also of all packaged meals, vegetables, and other items used in daily life. These items all lack quality since their temperature, moisture content, and oxygen content change frequently. Most consumers primarily focus on the information on the box, such as the number of components used and their nutritional worth, but they often forget that by disregarding the environmental factors that these packets are exposed to, they are putting their health in danger. Every company that makes products simply wants to draw in more and more customers, and its main goal is to sell the product in any way possible. 

For example, they may add more flavors, coloring agents, and preservatives to increase the product's taste and appearance, but they neglect to consider how these money-making strategies may affect the health of their customers. High relative humidity and temperatures encourage the growth of post-harvest degradation microbes. Fungi typically targets more acidic tissue, but fruits and vegetables with pH levels above 4.5 are generally immune. 
Ensuring food quality and safety is of paramount importance in the modern food industry. The emergence of Internet of Things (IoT) technology has opened new possibilities for monitoring and supervising food quality throughout the supply chain. Integrating IoT devices and sensors into food production and distribution processes allows real-time data to be collected, analyzed, and acted upon to detect and prevent potential quality issues. This project, titled "Supervision on Food Quality using IoT," aims to leverage the power of IoT to create a comprehensive system that ensures the highest standards of food quality.
Literature survey
In this chapter we discuss food quality monitoring systems that currently exist or have been proposed giving both their strengths and weaknesses. A study on our proposed system is done comparing it with these food quality monitoring systems focusing more on how our system addresses their weaknesses. We also do a comprehensive literature study of various components that are likely to be used in the realization of our proposed solution. The study of the components covers areas such as their mode of operation, features, specifications, uses, applications, advantages, and disadvantages.

[1] Manual monitoring of atmospheric and environmental factors:
Strengths:

· Provides some level of monitoring by personnel.

· Can detect changes in the conditions of the food store.

· Requires minimal initial setup.
Weaknesses:

· Relies on periodic visits by personnel, leading to delays in identifying and addressing issues.

· Increased labour and costs associated with routine checkups.

· Risk of injury or harm to personnel due to extreme conditions.

· Potential for human errors in measurements.

[2] Installed Measurement Devices monitoring systems:

Strengths:

· Improves upon manual monitoring by installing measurement devices.

· Can provide more accurate and continuous monitoring of environmental factors.

· Enables data collection for analysis and decision-making.
Weaknesses:

· Lacks automatic relay of information, requiring physical visits to access data.

· Delays in reading measurements due to manual retrieval.

· Device failures and maintenance requirements can impact reliability.

· May require additional costs for equipment installation and maintenance.
[3] Smart Food Quality Monitoring System:
Strengths:

· Systematic use of sensors for quality monitoring and control.

· Automation of tasks leads to better monitoring.

· Utilizes IoT technology for real-time data transmission.

· Cost-saving benefits by optimizing monitoring processes.

· Provides an interface for users to observe product quality evolution.

Weaknesses:

· Implementation and integration of various sensors and IoT components may require technical expertise.

· Initial setup and configuration can be complex.

· Potential challenges in data management and security.

· Reliance on wireless connectivity may introduce vulnerabilities.

In comparison, the manual monitoring system has limitations due to its reliance on human intervention and the potential for delays and errors. The installed measurement devices system improves upon manual monitoring but still lacks real-time data access. The smart food quality monitoring system offers automated and real-time monitoring using sensors and IoT technology, addressing the shortcomings of the other systems. However, it may require technical expertise for implementation and data management considerations.

By leveraging heterogeneous sensors, real-time data transmission, and data analysis capabilities, the proposed smart food monitoring system aims to overcome the limitations of existing solutions and provides advantages such as improved monitoring, cost savings, and time efficiency.

1.1 Design and implementation 
In this chapter we show how each component is interfaced with the microcontroller to form the smart IoT food quality monitoring system. The study chose to use a DHT-11 temperature and humidity sensor, MQ4 Sensor, the LDR sensor and ESP32 as the microcontroller.
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Fig.1.1 Block Diagram for Supervision on food quality using IOT
A block diagram is a diagram of a system that shows its various components and their interactions.
The room's gas concentration is measured using a gas sensor, which also transforms the concentration variable to its equivalent voltage. Humidity sensors measure relative humidity, whereas temperature sensors detect the temperature of the air. To cut costs, the two sensors are frequently used in tandem. The light sensor is employed to gauge light intensity. The data from all the sensors is shown on the display device. The data gathered by the sensors is sent to the Internet by the monitoring system. Through an open-source Internet platform, the concerned parties can keep an eye on the food store's gas concentration levels, temperature, humidity, and light intensity.
1.2 Flowchart
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Fig.1.2Flow Chart forSupervision on food quality using IOT
The flow chart as shown in figure1.2 is the processes involved in the food quality monitoring system. The flow chart was used to determine the sequence of events and to help in writing the program for the system.
1.3 ImplementationSteps
Implementation Steps for Supervision on Food Quality using IoT:

Hardware Setup:

a. Connect the ESP32 DEVKIT controller to your computer.

b. Connect the Light Dependent Resistor (LDR) sensors to the appropriate pins on the ESP32 DEVKIT.
c. Connect the DHT Temperature and Humidity Sensors to the ESP32 DEVKIT.
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          Figure 1.3.1 Interfacing DHT11 sensor  with ESP32
d. Connect the MQ-4 Gas Sensor to the ESP32 DEVKIT.
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Figure 1.3.2 MQ-4 sensor

e. Connect the O-LED display to the ESP32 DEVKIT.
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Figure 1.3.3 Interfacing OLED with ESP32
f. Ensure that all the connections are secure and properly wired  as shown in the below figure1.3.4.
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                                Figure 1.3.4 overall interfacing 
Software Setup:

a. Download and install the Arduino IDE software on your computer.

b. Open the Arduino IDE and go to "File" > "Preferences." In the "Additional Boards Manager URLs" field, add the URL for the ESP32 boards package: "https://dl.espressif.com/dl/package_esp32_index.json".

c. Go to "Tools" > "Board" > "Boards Manager" and search for "esp32". Install the "esp32" boards package.

d. Select the appropriate ESP32 board from the "Tools" > "Board" menu.

e. Install the necessary libraries for the sensors and display. Go to "Sketch" > "Include Library" > "Manage Libraries" and search for the following libraries:
· DHT sensor library

· Adafruit SSD1306
· Adafruit GFX

f. Install the above libraries and make sure they are successfully installed.
Coding:

a. Open a new sketch in the Arduino IDE.

b. Start by including the necessary libraries at the beginning of your code.

c. Define the pin connections and other constants for the sensors and display.
d. Set up the initializations and configurations in the setup () function.
e. Implement the main functionality in the loop () function.

f. Upload the code to the ESP32 DEVKIT by clicking on the "Upload" button in the Arduino IDE.
IoT Platform Configuration:

a. Create an account on the Arduino IoT Cloud platform (https://create.arduino.cc/iot).

b. Follow the platform's instructions to set up your device and connect it to the Arduino IoT Cloud.

c. Configure the necessary variables, properties, and settings on the IoT dashboard to display and analyse the sensor data.
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                                                    Figure 1.3.5 IOT results
Testing and Deployment:

a. Verify that the sensor values are correctly displayed on the OLED screen and can also be viewed on serial monitor.

b. Monitor the sensor data on the Arduino IoT Cloud platform.

c. Fine-tune the system as needed to ensure accurate monitoring and control of food quality.

d. Deploy the system in the desired location and ensure it is connected to the internet for remote monitoring and control.
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                                               Figure 1.3.6 Serial monitor output
Once it is properly installed and powered on, it connects with the internet via Wi-Fi modem and starts reading data from the interfaced sensors – DHT-11 temperature and humidity sensor, MQ4 Sensor and the LDR sensor. The ESP32 collects data from all the sensors and converts the values to the strings. The sensor data wrapped as proper strings are passed to the character OLED for display. Arduino cloud IOT platform was used to monitor the sensor data visually online.
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1.4 Conclusion
The implementation of an IoT-based system for food quality supervision offers significant benefits in enhancing food safety and quality control. Real-time data collection through IoT devices and sensors enables continuous monitoring and timely interventions. Data analytics and machine learning techniques improve the system's capabilities by analysing collected data to predict and prevent quality issues. The project highlights the importance of addressing challenges such as data security, integration with existing infrastructure, and scalability. Future advancements in IoT technology and emerging technologies can further revolutionize the food industry. Overall, the successful implementation of IoT for food quality supervision improves the safety and integrity of the food supply chain, ensuring consumer confidence.
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